Buddy - how to disable or not install


I’m trying Manticore 6.0.4 for Windows.

I have done the full install as recommended, everything works ok, but I have noticed increased memory usage over time.

One site with low hit rate (~0.3 searches / minute), and ~150,000 indexed documents, manticore has reached ~3GB memory over the last 2 days. Restarting the service the memory drops to 23MB.

Another site with a rate of 150~250 searches / minute, and ~218,000 indexed documents, it took about 2 hours for manticore to reach 12GB of memory. Restarting the service dropped this back to ~850MB, 2 hours later it was back up to 12GB. I have reverted this site back to 5.0.2 where it has sat stable at 850MB-900MB.

So I would like to either disable buddy, or install without, to see if this is causing the problem - I cannot see from manticore documentation how to do this? Is there a startup parameter, or searchd attribute? Or just install without executor?

many thanks

you could set buddy_path = # at the searchd section of config to disable start of the executor along with buddy

Do we need the buddy service at all?

Here’s the functionality which is not possible without Manticore Buddy:


  • Auto schema (creating a table automatically upon first insert)
  • _bulk endpoint for integration with Elasticsearch data ingestion tools
  • integration with JDBC


  • integration with mysqldump
  • /cli returning a table rather than json
  • integration with various mysql tools and clients (DataGrip.mysql, DBeaver etc., Grafana for mysql)
  • shards orchestration
  • many-many more

Manticore Buddy is going to be a vital part of Manticore Search. If there’s any problem with it - we want to fix it, not remove it.

1 Like