Error initializing ICU: Unable to initialize ICU break iterator: U_MISSING_RESOURCE_ERROR

Dear all:

I met a fetal error when trying to index some Chinese contents using manticore4.2 in Windows OS, it said that
"
using config file ‘./manticore.conf’…
indexing index ‘prnasia_index’…
FATAL: index ‘prnasia_index’: Error initializing ICU: Unable to initialize ICU break iterator: U_MISSING_RESOURCE_ERROR. Make sure ICU data file is accessible (using ‘/usr/share/icu’ folder)"

Confirmed that the ICU data file is in the folder: D:\manticore\share\icu\icudt65l.dat; and indexer is in D:\manticore\bin\indexer.exe.

According to the following post, seems that need to install manticore-icudata package, however, my system is Windows OS, did find how to install or specify the ICU data file folder. My Config file is attached here.
Indexer can index Chinese documents when removed " morphology = icu_chinese", but tokenization can’t be completed properly.

Can anyone please help me? Many thanks and apologize for asking such a junior question!

you could run indexer.exe -h command and it will print -DFULL_SHARE_DIR

Dear tomat

Many thanks for your reply. I saw that ’ Configured with these definitions: … -DLOCALDATADIR=/var/data -DFULL_SHARE_DIR=/usr/share’ after running ‘indexer.exe -h’.

I tried to add a new line ‘-DFULL_SHARE_DIR = d:\manticore\share’ in config file or run “indexer.exe --all -DFULL_SHARE_DIR = d:\manticore\share”, neither works. How can I fix this wrong file path, many thanks

you can not change the path but only put ICU data in that folder or rebuild binary from source with these new cmake definitions

Dear tomat

Many thanks for the message, understood, will try to rebuild binary from source code

you could also try to change these at runtime with environment variable FULL_SHARE_DIR or ICU_DATA_DIR

You need to change these prior to start of indexer or searchd

Dear tomcat

Many thanks for providing the solution, the problem solved after adding ICU_DATA_DIR into system variables and point it to the folder of icu data file.

After checking several Windows releases of Manticore, it turns out that all the LOCALDATADIR and FULL_SHARE_DIR were using Linux file path. Suggest fixing such minor bug in next release.

what should these path points into for Windows zip archive?

Could it be better to issue additional bat file the will set these sys variables? it should be run from current directory?

maybe better bat file~