Help me to retrieve data from the old index

I recently upgraded Manticore from 2.7.5-181204-4a31c54 to 5.0.2-220530-348514c86

This fixed many problems we had, but brought one new one. On startup I am receiving:

WARNING: index 'idx_web_log': prealloc: indexes with meta prior to v.14 are no longer supported
(use index_converter tool); /var/lib/manticore/data/idx_web_log.meta is v.13

I understand, index is old and needs to be converted. So I tried:

# index_converter --all
Segmentation fault

I put all index files separately into directory and run it with --path:

# ls -la ~/index/
total 936
drwxr-xr-x  2 root      root         101 Oct  8 01:33 .
drwx------ 11 root      root        4096 Oct  8 01:33 ..
-rw-------  1 manticore manticore      4 Oct  6 23:57 idx_web_log.kill
-rw-------  1 manticore manticore      0 Oct  7 02:36 idx_web_log.lock
-rw-------  1 manticore manticore    425 Oct  6 23:57 idx_web_log.meta
-rw-------  1 manticore manticore 942141 Oct  6 23:57 idx_web_log.ram
# index_converter --path ~/index/
Segmentation fault

Still no luck.

Then I decided to copy those index data to old Manticore instance with version 2.7.5. It started well, however it does not show any data now:

Server version: 2.7.5 4a31c54@181204 release 
> select * from idx_web_log;
Empty set (0.001 sec)

But when I run strings /var/lib/manticore/data/idx_web_log.ram I see all the data there. Is there any way how to dig it? I assume the index gets corrupted by my index_converter calls and now not old nor new Manticore can read it.

I would like to keep those data, even if they are just logs. Any ideas would be welcome, thanks!

could you try to use 3xx package first and convert your indexes into that version then to use that with recent release or convert into 5xx release version