Install and start on CentOS 7 without root access

The CentOS installation directions require that I have root access. I do not have that.

  • Is there a way to install it on CentOS 7 without root access? I was previously able to install Sphinx without root by using wget, tar, make. Is there a similar option for Manticore?

  • Can I start Manticore without root access? I can, for example, start Sphinx’s Searchd without root.

(Edit: I the server host will not install it. I need a way to do so without admin privileges.)

you can start \ stop daemon by hand with following commands searchd -c your.conf \ searchd -c your.conf --stop

Thanks. The server host just said they won’t install it so I need a way to install it without admin privileges as well.

just unpack package at your box and use binaries from destination folders or build binaries from source code

I’m not sure how to unpack the package (which package?) and how to build binaries. I see a section “Compiling on Linux systems” in https://docs.manticoresearch.com/latest/html/installation.html#compiling-manticore-from-source, but it seems quite general and uses yum command, which I do not have access to. Are there directions somewhere with the commands to run?

you could download a package for your OS from Github release page and unpack that package with pack \ unpack software for your OS

  • rpm - rpm2cpio ./package_name.rpm | cpio -idmv
  • deb - ar -xv ./package_name.deb

then use binaries from destination folder

I really appreciate your help, but you’re assuming that I have more knowledge than I do. I do not know how to “use binaries.” I’m really looking for some copy-paste installation directions, otherwise Manticore just isn’t right for my situation at this time.

I downloaded the manticore-3.4.2_200410.6903305-1.el7.centos.x86_64.rpm package (the only one with centos in the name as I use CentOS 7). I tried your rpm command, and received the following error, “cpio: premature end of archive”

you could use our support service https://manticoresearch.com/services/

or use docker image in case your box has container service enabled

Thanks. I entered a Consulting request. It doesn’t say anything about pricing. I guess I’ll see what they say.

Check if the RPM downloaded correctly.
Command md5sum manticore-3.4.2_200410.6903305-1.el7.centos.x86_64.rpm
should say 1a0ee3f890e099f04043b46c536e423a - if you get something else means the file didn’t downloaded correctly.
If you used curl to download the rpm, make sure you use -L flag as github links do a redirect (otherwise you end up with a html page downloaded - the rpm is about 19M in size).

I checked just now. It’s the right md5sum.

I get the same error even if I put in a file name that doesn’t exist.

I tried this:

rpm -i manticore-3.4.2_200410.6903305-1.el7.centos.x86_64.rpm

and get the error:

“error: can’t create transaction lock on /var/lib/rpm/.rpm.lock (Permission denied)”

Makes me think that I won’t be able to install from the rpm without admin privileges.

Run this in your terminal to download Manticore for Centos 7 (not as a package) and start it:

mkdir manticore_data_dir
wget http://dev.manticoresearch.com/tine_bak/searchd
wget http://dev.manticoresearch.com/tine_bak/indexer
wget http://dev.manticoresearch.com/tine_bak/manticore.conf
chmod +x searchd
./searchd -c manticore.conf
1 Like

Sergey, That seemed to do the trick! Thank you!!