Plain Index Windows Searchd Hanging

I’m trying to get a plain index to run (locally on Windows) importing data via sql query calling a local MariaDB.

Using the following config, indexer seemed to run fine (I can see the indexed files created), but then when I run searchd it just hangs (see output below). Note that I did have to add binlog_path to the default config because without that I was getting an error that no file or directory existed.

Also I did get the sample Real Time index working when following the manual. It is just the Plain Index I am having trouble with.

Can anyone help? Many thanks :slight_smile:

source m1 {
type = mysql
sql_host =
sql_user = root
sql_pass =
sql_db = phwrmhbm_dbnews
sql_query_pre = SET NAMES utf8
sql_query = SELECT id, cat_id, feedid, pubdate, item_headline, item_description, source, author, tags FROM alldata5 limit 100000
sql_attr_uint = cat_id
sql_attr_uint = feedid
sql_attr_timestamp = pubdate
index m1 {
path = C:/Manticore/var/lib/manticore/m1
source = m1
min_word_len = 3
min_prefix_len = 3
searchd {
listen =
listen =
listen =
log = C:/Manticore/var/log/searchd.log
query_log = C:/Manticore/var/log/query.log
pid_file = C:/Manticore/bin/
query_log_format = sphinxql
binlog_path = C:/Manticore/var/data

seems daemon works well. At Windows searchd does not detach and you need to launch it as start searchd.exe from console or run it as a service Manticore Search Manual: Installation > Windows

1 Like

Ah, so no problem after all. Thank you! :slight_smile:

Should Manticore not be showing as running in my Task Manager after starting the service? When I right click and click on Start it still shows as Stopped.

I just managed to fix it. I deleted the service and started again and it worked this time - I think the first install was pointing to a different config file. Apologies and thanks again :slight_smile: