Prevent substring searches with spaces

Query = CEO
Resultset = Service Organisator

Because Service Organisator contains CEO, but with space in it, it is in the resultset.

there are my relevant config settings
min_infix_len = 4
min_prefix_len = 1
expand_keywords = 1
charset_table = 0…9, A…Z->a…z, _, a…z, U+002E, U+26, U+23, U+40, U+410…U+42F->U+430…U+44F, U+430…U+44F, U+00EB->e, U+00CB->e, U+00EF->i, U+00CF->i, U+00E9->e, U+00C9->e, U+00E8->e, U+00C8->e, U+00F6->o, U+00D6->o, U+00EA->e, U+00CA->e, U+00FC->u, U+00DC->u, U+00D3->o, U+00E7->c, U+00C7->c, U+00E1->a, U+00C1->a, U+00E0->a, U+00C0->a, U+00E4->a, U+00C4->a, U+00FB->u, U+00DB->u, U+00EE->i, U+00CE->i, U+00ED->i, U+00CD->i, U+00F4->o, U+00D4->o, U+00FA->u, U+00DA->u, U+00F1->n, U+00D1->n, U+00E2->a, U+00C2->a, U+00E5->a, U+00C5->a

It seems the spaces are ignored + min_infix_len of 4 char is also ignored in this case.

Do I miss a config setting?

seems like a bug as it should not match Service Organisator with a CEO query.

Could you check that with reduced result set? ie with index only one document