unable to start the manticore service with data_dir in the config file

I am running manticore-3.5.4_210107 on centos7

Manticore is currently running and working very well…

I am trying to setup replication between 3 servers… I am starting with the first and added the following to the existing config file

server_id = 1
listen   = 10.156.3.49:9360-9370:replication
data_dir = /var/lib/manticore

the service will not start with the data_dir in the config file if I comment out that line it starts without issue.

I see the following the in the manticore.log file

[Thu Mar 18 13:09:47.767 2021] [46269] caught SIGTERM, shutting down
[Thu Mar 18 13:09:47.877 2021] [46269] shutdown daemon version ‘3.5.4 f70faec@210107 release’ …
[Thu Mar 18 13:09:47.877 2021] [46269] shutdown complete
[Thu Mar 18 13:09:47.882 2021] [46268] watchdog: main process 46269 exited cleanly (exit code 0), shutting down
[Thu Mar 18 13:09:47.882 2021] [46268] watchdog: got error 10, No child processes

I verified that the data_dir is owned by the manticore user and the user has write permission…

To ruled out permissions by doing a 777 on the directory. I have also disabled selinux.

Any help would be appreciated. here is the full config file

searchd
{
server_id = 1
listen = 9312
listen = 9306:mysql41
listen = 10.156.3.49:9360-9370:replication
#node_address = 10.156.3.49
#binlog_path = /var/lib/manticore
data_dir = /var/lib/manticore
log = /var/log/manticore/manticore.log
query_log = /var/log/manticore/query.log
query_log_format = sphinxql
max_threads_per_query = 8
network_timeout = 30
max_children = 0
max_batch_queries = 200
pid_file = /var/run/manticore/searchd.pid
seamless_rotate = 1
preopen_indexes = 1
unlink_old = 1
subtree_docs_cache = 12M
subtree_hits_cache = 16M
expansion_limit = 120
workers = threads # for RT to work
#Depricated
#compat_sphinxql_magics = 0
binlog_path = # disable logging
}

the service will not start with the data_dir in the config file

I see the following the in the manticore.log file

[Thu Mar 18 13:09:47.767 2021] [46269] caught SIGTERM, shutting down
[Thu Mar 18 13:09:47.877 2021] [46269] shutdown daemon version ‘3.5.4 f70faec@210107 > release’ …
[Thu Mar 18 13:09:47.877 2021] [46269] shutdown complete
[Thu Mar 18 13:09:47.882 2021] [46268] watchdog: main process 46269 exited cleanly (exit code 0), shutting down
[Thu Mar 18 13:09:47.882 2021] [46268] watchdog: got error 10, No child processes

Please provide more lines from the searchd log as these are about shutting down, they don’t explain why the instance won’t start.

BTW have you seen this course https://play.manticoresearch.com/replication
You can see there config examples and the replication works there.

There was nothing else in the searchd.log. I watched /var/log/messages closer this time and found the error that was preventing startup, kicking myself for missing it yesterday.

FATAL: ‘data_dir’ cannot be mixed with index declarations in ‘/etc/manticoresearch/manticore.conf’

The documentation is clear that local indexes are not supported with the data_dir option. Time to learn howto create and manage RT indexes. Thanks for the reply.

I did see the course… Very well done. Your documentation and resources are much better than most linux apps.