Unexpected result from HTTP API


#1

Hi all,

We’re brand new to Manticore - have literally just installed it on CentOS 7 and are experimenting.

We’ve migrated a config we’ve been using under Sphinx for years, and the indexer has built everything seemingly okay.

However, we’ve just tried the HTTP API, and it appears to b0rk out:

"
[root@g000003 sphinx]# curl -X POST ‘http://it-sphinx-server:9306/search’ -d ‘index=idx_productdata&match=@item_description drill&select=item_code,part_no,brand_name&limit=5’
2.7.5 4a31c54@181204 release �!
[root@g000003 sphinx]#
"

Given that this is just a simple query, shouldn’t this just work, or have we potentially misconfigured something?

Thank you!

Elliot


#2

9306 could be SphinxQL port. However you have to setup http port like

listen = 9380:http

then curl -X POST ‘http://it-sphinx-server:9380/search ...


#3

Hi Tomat,

Thank you very much for your reply.

That makes sense now! However, I have added
listen = 9380:http
to our /etc/sphinx/sphinx.conf settings (under the searchd section), and restarted the service, but when querying, I get:

[root@g000003 sphinx]# curl -X POST ‘http://it-sphinx-server:9380/search’ -d ‘index=idx_productdata&match=@item_description drill&select=item_code,part_no,brand_name&limit=5’
curl: (7) Failed connect to it-sphinx-server:9380; Connection refused

If I run netstat -tulnp, port 9380 doesn’t show as open:

[root@g000025 downloads]# netstat -tulnp Active Internet connections (only servers) Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name tcp 0 0 127.0.0.1:199 0.0.0.0:* LISTEN 2772/snmpd tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 2895/sshd tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 2858/master tcp 0 0 0.0.0.0:9306 0.0.0.0:* LISTEN 13896/searchd tcp6 0 0 :::22 :::* LISTEN 2895/sshd tcp6 0 0 ::1:25 :::* LISTEN 2858/master udp 0 0 0.0.0.0:68 0.0.0.0:* 2493/dhclient udp 0 0 0.0.0.0:161 0.0.0.0:* 2772/snmpd udp 0 0 127.0.0.1:323 0.0.0.0:* 1924/chronyd udp6 0 0 ::1:323 :::* 1924/chronyd [root@g000025 downloads]#

Despite the config change and service restart, it doesn’t look like Manticore is listening for the HTTP connection on port 9380. Is it a separate service? Or have I put the config option under the wrong section?

Thanks!


#4

for listen = 9380:http it listen local address you have to use listen = 0.0.0.0.:9380:http to accept inet clients or provide another valid inet address


#5

Perfect!

Thank you, Tomat. All working now :slight_smile: