WARNING: sort_hits: merge_block_size=44 kb too low

Hi every one,

How i can fix that warning : “WARNING: sort_hits: merge_block_size=44 kb too low, increasing mem_limit may improve performance” ?
My indexing process is slow and i have to wait for 6 hours (80M rows for 100G Mysql Table)

Any clue on how i can increase this value ?

You can increase mem_limit by setting a larger value in the indexer section of your config file - Manticore Search Manual: Data creation and modification > Adding data from external storages > Plain tables creation

I’d also make sure Manticore is a bottleneck and not the storage you are indexing from. Also, ranged queries often help.