why cannot connect to the manticore docker server

I executed the commands in the docs to install manticore in docker, but the mysql client always reports errors that it can’t connect, at the same time I pulled a mysql image, and the local client is able to connect to mysql, I don’t know what the problem is, can someone please help me out, below are some of the commands, screenshots, and configurations i used

docker pull manticoresearch/manticore

docker run -e EXTRA=1 --name manticore -v $(pwd)/manticore.conf:/etc/manticoresearch/manticore.conf -v $(pwd)/data:/var/lib/manticore/ -p 9306:9306 -p 9308:9308 -d manticoresearch/manticore

i have removed,the ip is and when i executed mysql -P9306 -h0
it reported errors

but i can access mysql docker container server

here is the conf

ip=`hostname -i|rev|cut -d\  -f 1|rev`
cat << EOF
searchd {
    data_dir = /var/lib/manticore

    listen = 9306:mysql41
    listen = /var/run/mysqld/mysqld.sock:mysql41
    listen = $ip:9312
    listen = 9308:http
    listen = $ip:9315-9325:replication

    # https://manual.manticoresearch.com/Server_settings/Searchd#log
    log = /var/log/manticore/searchd.log

    max_packet_size = 128M

    pid_file = /var/run/manticore/searchd.pid

common {




could you post searchd.log or log from the container there daemon posts on startup what it listens?


docker logs manticore

is there any problems?

could you try mysql -h -P 9306 ?

still error…

could you check who occupies the port 9306? at your box as error on reading initial communication packet means that mysql is reading data from that port and the data is wrong but something communicating with the mysql client

here is the result

maybe these two containers should not listen the same port?

actually there is only one manticore container,

what shoud i do?

need reproducible example as for me it works as usual

docker run -e EXTRA=1 --name manticore111 -p 29306:9306 -d manticoresearch/manticore
docker ps | grep 126e5349e6fd
126e5349e6fd   manticoresearch/manticore                             "docker-entrypoint.s…"   About a minute ago   Up About a minute       9308/tcp, 9312/tcp,>9306/tcp, :::29306->9306/tcp                                  manticore111
sudo lsof -i :29306
docker-pr 334141 root    4u  IPv4 2151042668      0t0  TCP *:29306 (LISTEN)
docker-pr 334147 root    4u  IPv6 2151067658      0t0  TCP *:29306 (LISTEN)
$ mysql -h0 -P 29306
Your MySQL connection id is 11
Server version: 6.2.12 dc5144d35@230822 (columnar 2.2.4 5aec342@230822) (secondary 2.2.4 5aec342@230822) git branch manticore-6.2.12...origin/manticor-6.2.12

Well, I’ve tried many times, changed a few linux VMs to start manticore with docker install, and it’s all the same error…I don’t know what went wrong
i tried your command

It’s still the same error…

do you use Mac MX notebook?

google for mysql docker got an error reading communication packets shows alot of topic
and one docker-and-mysql-got-an-error-reading-communication-packets suggests to

Same issue appeared on M1 M2 M3 arm chip. Just have to disable “Use Rosetta for x86/amd64 emulation on Apple Silicon” in Docker configuration and it works fine.

you could also try to use cheap VPS for example at the DigitalOcean there try to recreate this behavior then provide access to it to investigate the issue further

i use win book and vmvare,
thank you for your answer,i appreciate it !

@tong_yaoyu have you solved the issue?

actually,I still can not connect to the manticore docker server
I tried many times on a new server
run the command from the official documentation

docker run -e EXTRA=1 --name manticore -v $(pwd)/data:/var/lib/manticore -p 9306:9306 -p 9308:9308 -d manticoresearch/manticore

and run command

mysql -h -P 9306

get the error

but i can connect to the mysql container

so weird…so is there something wrong in the mantiocre docker image?

As I suggests you could also try to use cheap VPS for example at the DigitalOcean or any other there try to recreate this behavior then provide access to it to investigate the issue further. That allows to eliminate the influence of your local box to the setup and made the case the reproducible in the controlled environment.

You could also compare the VPS ports \ permissions to these you see at your local box.

I just execute the commands according to the official documentation, very simple few commands, tried it on VMware, macos, linux servers, and I get the same result.

seem something wrong at your setup as we have developers with the MacOS these use Docker images along with the Linus boxes there Docker containers work without issues. From my point all works fine.

That is why I suggests to use some environment the you could recreate case and we could investigate it.